Messed up my system completely

Discussion in 'Software & Applications' started by vtlx, Feb 26, 2016.

  1. vtlx

    vtlx Thread Starter
    Expand Collapse
    New Member

    Feb 26, 2016
    Likes Received:
    I did something very stupid and now trying to get my system back to work (not successful so far)! Need your help guys.
    Yesterday I was trying to make deepin player work and found some bug report that suggested to install libgtk2.0 and lib...2.4 something (don't remember exactly). So I did. It didn't help, but my Firefox started crushing. I figured it could have been because of those two packages. So, I did very dumb thing: In terminal I wrote
    sudo apt-get purge libgtk2.0 lib...2.4

    When I noticed this command removing everything and icons started disappearing from my computer I stopped it, but after rebooting I couldn't pass the login screen. When I enter my password and push ENTER nothing happens.
    I've already tried fixing things in recovery mode. Here's what I did:
    In the recovery terminal connected to the internet and tried to repair broken packages.
    I've tried
    apt-get update
    apt-get dist-upgrade
    apt-get autoremove
    apt-get clean
    apt-get build-dep build-essential

    I also did
    apt-get -f install

    and to find packs with broken dependencies
    dpkg --configure -a

    then dpkg --configure -a --force-depends

    I've tried to reinstall elementary environment by
    apt-get install --reinstall elementary-desktop
    apt-get install gala pantheon-files pantheon

    But nothing helped. Can someone please give me some anvise how to get everything back?

    P.S. Now when I enter dpkg --configure -a I get something about bluez and the file invoke-rc.d with invalid instance.

Share This Page