Hera Installing Windows .exe

Discussion in 'Software & Applications' started by Renoux, Mar 11, 2020.

  1. Renoux

    Renoux Thread Starter
    Expand Collapse
    New Member

    Joined:
    Mar 11, 2020
    Messages:
    1
    Likes Received:
    0
    Hi guys.

    I have installed Lutris, Wine and PlayOnLinux with no avail.

    I just cant seem to install the latest Rimworld .exe package to this OS.

    I am new to Elementary but used to POP_OS and Mint.

    I get this error when trying to update or uninstall Wine from the appcenter:

    The following packages have unmet dependencies:
    libwine-development: Depends: libopenal1 (>= 1.14) but it is not going to be installed
    Depends: ocl-icd-libopencl1 but it is not going to be installed or
    libopencl1
    Depends: ocl-icd-libopencl1 (>= 1.0) but it is not going to be installed or
    libopencl-1.1-1
    Recommends: libcapi20-3 but it is not going to be installed
    Recommends: libodbc1 (>= 2.3.1) but it is not going to be installed
    Recommends: libosmesa6 (>= 10.2~) but it is not going to be installed
    Recommends: fonts-wine (>= 1.8.2-1~) but it is not going to be installed
    libwine-development: Depends: libfontconfig1 (>= 2.12) but it is not going to be installed
    Depends: libfreetype6 (>= 2.2.1) but it is not going to be installed
    Depends: libasound2 (>= 1.0.16)
    Depends: libglib2.0-0 (>= 2.12.0) but it is not going to be installed
    Depends: libgphoto2-6 (>= 2.5.10) but it is not going to be installed
    Depends: libgphoto2-port12 (>= 2.5.10) but it is not going to be installed
    Depends: libgstreamer-plugins-base1.0-0 (>= 1.0.0) but it is not going to be installed
    Depends: libgstreamer1.0-0 (>= 1.4.0) but it is not going to be installed
    Depends: liblcms2-2 (>= 2.2+git20110628) but it is not going to be installed
    Depends: libldap-2.4-2 (>= 2.4.7) but it is not going to be installed
    Depends: libmpg123-0 (>= 1.13.7) but it is not going to be installed
    Depends: libopenal1 (>= 1.14) but it is not going to be installed
    Depends: libpcap0.8 (>= 0.9.8) but it is not going to be installed
    Depends: libpulse0 (>= 0.99.1) but it is not going to be installed
    Depends: libx11-6 but it is not going to be installed
    Depends: libxext6 but it is not going to be installed
    Depends: libxml2 (>= 2.9.0) but it is not going to be installed
    Depends: ocl-icd-libopencl1 but it is not going to be installed or
    libopencl1
    Depends: ocl-icd-libopencl1 (>= 1.0) but it is not going to be installed or
    libopencl-1.1-1
    Recommends: libcapi20-3 but it is not going to be installed
    Recommends: libcups2 (>= 1.4.0) but it is not going to be installed
    Recommends: libdbus-1-3 (>= 1.9.14) but it is not going to be installed
    Recommends: libgl1 but it is not going to be installed
    Recommends: libglu1-mesa but it is not going to be installed or
    libglu1
    Recommends: libgnutls30 (>= 3.5.0) but it is not going to be installed
    Recommends: libgsm1 (>= 1.0.13) but it is not going to be installed
    Recommends: libgssapi-krb5-2 (>= 1.6.dfsg.2) but it is not going to be installed
    Recommends: libjpeg8 (>= 8c) but it is not going to be installed
    Recommends: libkrb5-3 (>= 1.6.dfsg.2) but it is not going to be installed
    Recommends: libodbc1 (>= 2.3.1) but it is not going to be installed
    Recommends: libosmesa6 (>= 10.2~) but it is not going to be installed
    Recommends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
    Recommends: libsane1 (>= 1.0.24) but it is not going to be installed
    Recommends: libtiff5 (>= 4.0.3) but it is not going to be installed
    Recommends: libv4l-0 (>= 0.5.0) but it is not going to be installed
    Recommends: libxcomposite1 (>= 1:0.3-1) but it is not going to be installed
    Recommends: libxcursor1 (> 1.1.2) but it is not going to be installed
    Recommends: libxfixes3 but it is not going to be installed
    Recommends: libxi6 but it is not going to be installed
    Recommends: libxinerama1 but it is not going to be installed
    Recommends: libxrandr2 but it is not going to be installed
    Recommends: libxrender1 but it is not going to be installed
    Recommends: libxslt1.1 (>= 1.1.25) but it is not going to be installed
    Recommends: libxxf86vm1 but it is not going to be installed
    Recommends: libasound2-plugins but it is not going to be installed
    Recommends: fonts-wine (>= 1.8.2-1~)

    And then I get this error when trying to add the stable release on terminal:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    winehq-stable : Depends: wine-stable (= 5.0.0~bionic)
    E: Unable to correct problems, you have held broken packages.

    This happened as I followed an old thread that said install the sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ eoan main' repo. I realise that I am running bionic but I removed the above and still same issue.

    I just installed the OS so a format reload is probably on the cards for me.

    But for the love of god, can someone please give me a step by step to install Rimworld from an exe... Its the only game I play on pc (its not available on Xbone).
     

Share This Page

Loading...