Installing R on Freya problems

Discussion in 'Software & Applications' started by femmer, Sep 17, 2016.

  1. femmer

    femmer Thread Starter
    Expand Collapse
    New Member

    Sep 17, 2016
    Likes Received:
    I am having the following errors trying to install R:

    The following packages have unmet dependencies:
    r-base : Depends: r-base-core (>= 3.3.1-1xenial0) but it is not going to be installed
    Depends: r-recommended (= 3.3.1-1xenial0) but it is not going to be installed
    Recommends: r-base-html but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    I tried:
    Uninstall old R:

    sudo apt-get remove r-base-core


    sudo gedit /etc/apt/sources.list

    Add the following to the file:

    deb precise/

    and exit gedit.

    Then copy/paste these commands into the command line:

    sudo apt-key adv --keyserver --recv-keys E084DAB9

    sudo add-apt-repository ppa:marutter/rdev

    sudo apt-get update

    sudo apt-get upgrade

    sudo apt-get install r-base

    Still not working, any suggestions?

    Fixed this issue. I needed to edit the etc/apt/sources.list file to point to trusty and not xenial
    #1 femmer, Sep 17, 2016
    Last edited: Sep 18, 2016

Share This Page