Answered Install WINE Application

Discussion in 'Newbie Questions' started by Mohammad Refly, Apr 21, 2015.

  1. Mohammad Refly

    Mohammad Refly Thread Starter
    Expand Collapse
    New Member

    Joined:
    Apr 21, 2015
    Messages:
    2
    Likes Received:
    0
    How to install Wine at ElementaryOS Freya 64 Bit ? :cool:
    I'am newbie linux :oops:
    Please help me :)
     
  2. paradise

    paradise
    Expand Collapse
    Elementary Supporter

    Joined:
    Dec 3, 2014
    Messages:
    123
    Likes Received:
    33
    Hello Mohammad,

    welcome to Linux :)!
    Inside of your official Software Center Program you'll find an old-stable version from WINE:

    install old wine normal way.jpg

    But WINE has received further releases the last months/weeks, so there are newer versions which you can't find in this Software Center. For this installation it's more easy to copy&paste the installation in your terminal with an Ubuntu PPA (External Repository):

    Code (Text):
    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    Install the latest stable Version (1.8.x):
    Code (Text):
    sudo apt-get install wine1.8
    Or, for the most newest developer Version (often best results):
    Code (Text):
    sudo apt-get install wine1.9
    With this in your Terminal, you see which version is installed:
    Code (Text):
    wine --version
    Does it work :)?

    /Edit: Updated, latest stable=v1.8, latest developer (unstable)=v1.9
     
    Mohammad Refly likes this.
  3. Mohammad Refly

    Mohammad Refly Thread Starter
    Expand Collapse
    New Member

    Joined:
    Apr 21, 2015
    Messages:
    2
    Likes Received:
    0
    thank you
    it's work
     
  4. dagolinuxoid

    dagolinuxoid
    Expand Collapse
    Member

    Joined:
    May 30, 2015
    Messages:
    7
    Likes Received:
    0
    Hi! I have some troubles (First of all my destro is Elementary OS Luna x64 )
    Code (Text):

    linux@linux-desktop:~$ sudo apt-get install wine1.7
    Reading package lists... Done
    Building dependency tree    
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.18-0ubuntu1) but it is not going to be installed
               Depends: wine1.7-i386 (= 1:1.7.18-0ubuntu1)
    E: Unable to correct problems, you have held broken packages.
    linux@linux-desktop:~$
    Or through Synaptic and of course I cancelled it. Any idea? PS. Sorry for long image)) , possible insert spoiler here?
    Or through Synaptic [​IMG]
     
  5. paradise

    paradise
    Expand Collapse
    Elementary Supporter

    Joined:
    Dec 3, 2014
    Messages:
    123
    Likes Received:
    33
    This can't work. WINE 1.7.18 is not the latest version from this PPA. As you can see here, 1.7.38 is the latest one:

    https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa/+index?batch=75&memo=75&start=75

    wine_install.jpg
    Is there an issue with your repository? Could you update everything and try again?

    Code (Text):
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get -f install
    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.7
     
  6. dagolinuxoid

    dagolinuxoid
    Expand Collapse
    Member

    Joined:
    May 30, 2015
    Messages:
    7
    Likes Received:
    0
    Unfortunately same story (before also was
    ppa:ubuntu-wine/ppa repository, its pretty weird, I mean 1.7.18 version)
    Code (Text):

    linux@linux-desktop:~$ sudo apt-get install wine1.7
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.18-0ubuntu1) but it is not going to be installed
    Depends: wine1.7-i386 (= 1:1.7.18-0ubuntu1)
    E: Unable to correct problems, you have held broken packages.
    linux@linux-desktop:~$
     
  7. myviolinsings

    myviolinsings
    Expand Collapse
    New Member

    Joined:
    Aug 15, 2018
    Messages:
    1
    Likes Received:
    0
    I followed @paradise instructions for installing wine 1.8 since 1.6 is still the default in app center. After terminal finished I tried to run wine and got a message saying some .net files were missing in order to run wine. The message had a note: it is recommended to use your distribution's packages instead and included a link or "install", I chose install. Then a new message popped up saying Wine could not find a Gecko package and included a link to here: https://wiki.winehq.org/Gecko but there is no 64 .msi files listed for v. 1.8. Should I install the 1.9 (unstable)? I am new to linux and using elementary os loki. Currently, the Wine Gecko Installer message is displayed on my screen and behind it was a Wine message saying The Wine configuration in (my home directory) is being updated please wait...
    I could use your help to get wine up and running. Thanks.
     

Share This Page

Loading...