Loki Install process is broken

Discussion in 'Installation' started by pupil, Jan 24, 2018.

  1. pupil

    pupil Thread Starter
    Expand Collapse
    New Member

    Jan 24, 2018
    Likes Received:
    Hardware is an HP Stream/netbook (AMD64/R3 1GHz, 2Gb RAM, 32Gb disk)

    Elementary OS live boot ISO/USB works. Watched random youtube cats (not very amusing) and the fact that it worked makes me think hardware support is good enough to warrant installing.

    BIOS: UEFI disabled, secure boot disabled, and legacy boot mode enabled (order is USB then HDD)

    Boot menu: Install Elementary OS.

    Loading screen (ALT+CTRL+ESC displays console and all OK).
    Elementary Install GUI (first problem: ALT+CTRL+ESC displays only blank screen, why?)
    Elementary connects to Wi-Fi (OK)

    Next set of options:
    Install updates [YES/NO]
    Install multimedia support [YES/NO]

    I have tried every possible combination of the above YES/NO questions. Clicking Next has the same outcome: pointer becomes a spinner, and there is no other observable activity.


    1. If the installer is busy working, how long should the above questions remain visible in the GUI?
    2. How do I view the console output while the installer is working?
    3. How many hours must we wait until we are certain this isn't working?
    4. Where are the log files?


    Tried running installer from Elementary OS desktop, after a long wait a popup notifies: "Install" is not responding. Sadly that is not new information, but what I learned is that the spinner does not return to being a pointer when applications die. I sudo killed some odd ends and "top" shows only 3 running tasks (top, Xorg, terminal) with CPU 99% free. I assume the offending task is in a vegetative state, and that the persisting spinner is misinformation. Is there any way to find out which task prompted the spinner?

    Can someone please help me to install Elementary OS?

    Edit 2:

    "HP" (maybe just OEM branding on MS Windows) detects changes and starts-up Automatic Repair. Will that feature be blatted when a new OS is installed?

    Edit 3:

    Installed AMD microcode update in case there was something amiss with the power management drivers, and I then ran the installer. This made no difference.

    Other observations:

    /sda3 is being mounted read-only. BIOS presents no ACPI options.
    #1 pupil, Jan 24, 2018
    Last edited: Jan 24, 2018

Share This Page