How eOS update broke my system and how I fixed it.

Discussion in 'Discussions' started by headsign, Jul 5, 2018.

  1. headsign

    headsign Thread Starter
    Expand Collapse
    New Member

    Jul 5, 2018
    Likes Received:
    So I installed a fresh eOS (Loki) on an old Macbook 2,1 from 2007 and it worked fine until the last update.
    What happened was the system started to boot very slowly and then I got into the dreaded login loop. Reinstalled, updated again, same result.

    I'm not a Linux expert. Know my way around like a flip-flops-wearing minigolf player on an actual golf course. So, first rule: no system update. No so great. So I did what I usually do: install Synaptic Package Manager (it's like the AppCenter, but with all the stuff they don't show you) and install crazy risky stuff because this system is far from being vital.

    Anyway at some point, I was looking for an alternative for the touchpad driver because the generic one feels horribly jaggy, so I uninstalled it and instead, marked the Synaptics driver for installation, which dragged a complete system update after it. Ugh! System update. But lo and behold, not only is the jaggy mouse pointer fixed but the system is declared as up-to-date. Great!

    So to anyone with a similar problem. There's not much useful info about solutions on the internet and my problem report on stackexchange has been sitting unanswered since yesterday: just try this as ultimate solution: install Synaptics (because it makes fiddling with your system much, much easier) and look for the Synaptics Xorg drivers and replace the existing drivers with those. You might have found a solution. If not: not my fault. It's those damn lazy programmers ;)

    Now seriously, programmers are like wizards to me and earn my full respect :)
    #1 headsign, Jul 5, 2018
    Last edited: Jul 5, 2018

Share This Page