Headphones not working

Discussion in 'Newbie Questions' started by fnilob, Mar 30, 2020.

  1. fnilob

    fnilob Thread Starter
    Expand Collapse
    New Member

    Joined:
    Mar 30, 2020
    Messages:
    1
    Likes Received:
    0
    Hello.
    I'm new with elementaryOS and i don't know why my headphone audio suddenly stop working.
    I have run alsa-info to get this:

    http://alsa-project.org/db/?f=484092b5a92e6e810267155cbfb38bd6bfb39a74

    I also tried to give gain to headphones in alsamixer, and also to restore the default configuration.

    My alsa-base.conf:

    GNU nano 2.9.3 /etc/modprobe.d/alsa-base.conf

    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS $
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS $
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS $

    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sb$
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2
    options snd_hda_intel enable=1 index=0
    options snd_hda_intel enable=0 index=1

    I have been with this problem almost three days so i need help.

    Thanks people.
     
  2. Victor Rodriguez

    Victor Rodriguez
    Expand Collapse
    New Member

    Joined:
    Oct 2, 2020
    Messages:
    1
    Likes Received:
    0
    Hi
    ┬┐Did you find a solution?
     
  3. adwilson99

    adwilson99
    Expand Collapse
    Active Member

    Joined:
    May 2, 2020
    Messages:
    43
    Likes Received:
    6
    Sorry if you were not able to get an answer. Assuming you didn't change the headset and have verified that the headset works in other devices (e.g. phone etc) then lets rule out the headset. Also please confirm is this a bluetooth headset or wired headset?

    Next can you screenshot your alsamixer settings (lets see if anything odd in there).

    For example, in my case the settings look like this, makesure headphone is enabled and the volume moves up and down correctly.

    [​IMG]

    be good if you could post your settings.
     

    Attached Files:

Share This Page

Loading...