Loki GRUB unable to write outside hd0 after bad BIOS reset [Solved]

Discussion in 'Newbie Questions' started by Lice, Mar 21, 2017.

  1. Lice

    Lice Thread Starter
    Expand Collapse
    New Member

    Mar 21, 2017
    Likes Received:
    I left to travel for 1 month and my computer started to present two problems. After several attempts I discovered that there was oxidation in the memories and power supply had broken (two problems). During the tests I reset the BIOS of the computer incorrectly, I forgot to completely disconnect the power cable and generating a bad reset (the computer turned itself on during the process of removing the jumper).

    I started getting the following error
    Error trying to read or write off the `hd0` disk
    GRUB Recover>
    1. first I tried to format HD, but I was not able to get into the particle creation stage at all.
    After many attempts, I found a tutorial saying to write the following things in GRUB to fix the problem
    Set root = (hd0, msdos1)
    Set prefix = (hd0, msdos1) / boot / grub
    Normal insmod
    OBS> During the `insmod normal` command I received the error again from trying to read and write off the HD0 disk. At one point, I was simply become able to execute the command.
    2. I tried to use BOOT Repair to recover the system, I did not succeed
    3.Then I tried re-installing the system. I was able to access the HD parts during the installation. I tried to format Elementary the first time and an error occurred during the installation `creating the directory .usr / src / linux-headers-4.4.0-66`
    On the second attempt I deleted all partitions and managed to install the elementary.
    OBS> During that time, I tried to install another LINUX distribution (Deepin 15.3), but the installation stopped during the partitions creation stage as well.
    3. Now with Elementary installed, after BOOT it gets infinitely on the screen with the elementary logo, (when I press F2 to see what is happening, in a given step it goes into an infinite loop trying to execute something)
    4. I tried BOOT Repair again, this time it worked normally getting the Repair message completed, but the problem persisted.
    5. I updated the BIOS of my motherboard, and the problem persisted.
    6. I am writing this thread through `try Elementary OS without install it` mode, from a USB flash drive.
    I have no idea how to solve this problem and re-run the system normally.
    OBS1> All my files are stored in the cloud, any solution that involuntarily deletes all my files and is acceptable.
    OBS2> I DO NOT use dual boot, so I do not know why I had problems with GRUB
    OBS3>I can run the system through a bootable USB flash drive, but not through the system installed on the HD.

    OBS4> I`m starting to think about installing an operating system other than Linux, to see if the problem is solved. Because HD0 as far as I know is a linux folder.

    Final OBS> Any help is welcome, I am a student of computer science, and I need this computer to work again as soon as possible to study.

    (Sorry for the bad english, here are a few pictures of the problem)

    After all this steps, my last try was installing Elementary OS in the advanced mode, and making just two partition ( ext4 for my files and Swap), thus ignoring EFI partition needed. The system become functional again.
    erro1.JPG erro 2.JPG erro3.JPG
    #1 Lice, Mar 21, 2017
    Last edited: Mar 21, 2017

Share This Page