Loki Display Flickering with Kaby Lake

Discussion in 'Hardware Support' started by Sean Rhodes, Feb 22, 2017.

  1. Sean Rhodes

    Sean Rhodes Thread Starter
    Expand Collapse
    New Member

    Feb 22, 2017
    Likes Received:

    I got a Razer Blade Stealth recently and installed elementary OS on it. It's the Kaby Lake version so it has the Intel HD 620.

    The issue I have:

    - Display Flickering running at native resolution, the display flickers aggressively to the point that its unusable. Either dropping down the resolution to 1920x1080 or having an external monitor connected and its absolutely fine. I tried the "Intel-Microcode" and open source drivers but they don't change it at all. I also tried creating the .conf file but this made no difference.

    I tried installing Kernel 4.10 using Ukuu as this does stop the flickering when at the login screen. However, when signing in the machine will just crash.

    Does anyone know how to stop this or successfully get the 4.10 kernel working?

    I love elementary so don't want to go back to Ubuntu!

    Thanks :)
  2. DooshPastesh

    Expand Collapse

    May 8, 2017
    Likes Received:
    I had the same problem with Asus ux410ua with intel kabylake and intel graphics. I solved it by instaliing missing firmware.
    Run in terminal:

    sudo update-mkinitramfs -u

    It should tell you that there is possible missing firmware. Check which one is missing (GUC, DMC, HUC, and kbl, skl, bxt)

    go HERE and get those. Unpack them and in terminal run:

    sudo bash install.sh

    in each unpacked folder. Reboot and done.

Share This Page