Hera Black screen on boot with latest kernel 5.3.0-40-generic

Discussion in 'Hardware Support' started by Subharthi Kar, Feb 20, 2020.

  1. Subharthi Kar

    Subharthi Kar Thread Starter
    Expand Collapse
    New Member

    Joined:
    Feb 20, 2020
    Messages:
    1
    Likes Received:
    0
    Hello,
    I am using Elementary OS 5.1.2 Hera on my Lenovo Ideapad S145 with AMD Ryzen 3 3200U CPU. Everything was fine until an update on 18/FEB/2020 which upgraded my Linux kernel from 5.3.0-28-generic to 5.3.0-40-generic. Since then whenever I boot Elementary OS using the default option, i.e. the latest kernel I am greeted by a black screen instead of the Elementary logo. If it's of any relevance, during install the bash reported that OS could not find any display drivers for 'amdgpu' and 'navi20' or something similar. I am presently using the older kernel to use my computer. Kindly resolve this issue or suggest a workaround, as I am new to Linux and do not know any better.
    Much Thanks!
     
  2. adwilson99

    adwilson99
    Expand Collapse
    Member

    Joined:
    May 2, 2020
    Messages:
    8
    Likes Received:
    0
    What graphics card are you using? Did you have to compile a graphics driver previously?

    if you are able to boot with the new kernal version, try pressing the "CTRL + ALT + F1" keys at the same time, to see if it gives you a command line.

    If it does run the following command, and post the results here.
    Code (Text):
    dmesg
     

Share This Page

Loading...