Black screen after suspend

Discussion in 'Newbie Questions' started by thijsbs, Dec 6, 2016.

  1. thijsbs

    thijsbs Thread Starter
    Expand Collapse
    New Member

    Joined:
    Dec 4, 2016
    Messages:
    1
    Likes Received:
    0
    Hello everyone. I recently switched to elementary os (loki) and I love it so far. However, I am experiencing some problems. I am very new to Linux and find myself not really knowing what i'm doing most of the time when trying to solve these problems myself.
    The issue that I am having is that after waking up from suspend my computer freezes on a black screen. This happens after closing and opening my laptop. When I attempt to wake the computer back up after having clicked on "Suspend" from the menu, I am greeted with a lot of text, ending in a kernel panic message.

    I found two possible solutions for this online. One is to install graphic card drivers. And another to install a different kernel version. Neither of these solutions worked out for me.

    I have an AMD Radeon R7 M440 graphics card. The "Additional Drivers" utility does not seem to recognize this showing only: "Unknown: Unknown" and "This device is not working". The driver from amd.com which should work on Ubuntu 16 causes me to not be able too boot at all (black screen after grub). I'm afraid that at this point I am at a dead end as far as the drivers are concerned. I hope that someone has another suggestion.

    Another suggestion I found regarding the black screen after suspend was to install a different kernel version with the following command:
    Code (Text):
    sudo apt install linux-headers-4.4.0-36 linux-headers-4.4.0-36-generic linux-image-4.4.0-36-generic linux-image-extra-4.4.0-36-generic
    However this did not solve it for me. Also when I run:
    Code (Text):
    uname -r
    it shows that the kernel version is still 4.4.0-51-generic. I guess I just don't know what I'm doing. I hope someone can help!
     
  2. Bryan Chan

    Bryan Chan
    Expand Collapse
    New Member

    Joined:
    Jul 20, 2017
    Messages:
    1
    Likes Received:
    0
    Dear Sir,

    May I Know how do you install Loki with AMD Radeon R7 M440 ? because i'm tried to install to HP 15-ba004ax, while boot on option install elementaryOS, result I've got is kernel panic.
    I'm using Loki 0.4.1, do you using Loki 0.4 ?
    Thanks a lot
     
  3. Spilio1701

    Spilio1701
    Expand Collapse
    New Member

    Joined:
    Feb 23, 2019
    Messages:
    2
    Likes Received:
    1
    Greetings. I'm not sure of the etiquette here regarding old threads founds in search versus starting something new. And I did look first on StackExchange as the welcome email suggested. Mods, please forgive me if I've erred.

    I have a 2009 iMac, and installed the latest elementaryOS -- Juno, I believe it's called. With a little elbow grease, I've gotten everything working properly, but one problem persists.

    As the OP wrote: black screen after suspend.

    I actually don't have much data to provide, or experience with Linux to know where to get the information you may need. But observationally here's what happens:

    The system automatically goes to sleep or to suspend. (At first I left the default settings, but later disabled suspend and only allowed the screen to be put to sleep). Upon attempting to wake by moving the mouse, there is no visual feedback. Attempting a keystroke, no visual feedback. Attempting to check responsiveness by pressing a lock key (CAPS, NUM, SCROLL), and the appropriate LED does light up. But at that point, the LED stays lit and doesn't respond to being toggled, nor do other lock keys activate; at this point the system is -- apparently -- fully hung.

    I could use any and all advice/feedback.

    Thanks!
     
    nicoj likes this.
  4. nicoj

    nicoj
    Expand Collapse
    New Member

    Joined:
    Mar 14, 2019
    Messages:
    1
    Likes Received:
    0
    I have sort of the same problem.
    Everytime I leave my desktop computer for a while or try to change user in Juno it goes into a black screen with a blinking white bar and I can't recover from it using ctrl+alt+delete or any other way. Only way to leave it is to press the power button, which turns off the computer. I also disabled suspend and it still does it.
    And I'm not really sure what to do. I have the proper nvidia drivers for mi graphics card, which I read it could solve it but didn't. Any advice you have, I would be grateful
     
  5. Spilio1701

    Spilio1701
    Expand Collapse
    New Member

    Joined:
    Feb 23, 2019
    Messages:
    2
    Likes Received:
    1
    The Elementary community is dead. I tried getting help here and on other forums, and couldn't elicit a single response from anybody.

    In the end, I abandoned the platform entirely and installed Ubuntu.

    Cheers.
     
  6. klimbo

    klimbo
    Expand Collapse
    New Member

    Joined:
    Apr 14, 2019
    Messages:
    3
    Likes Received:
    0
    but you have to activate the other lock keys
     
    #6 klimbo, Apr 14, 2019
    Last edited: Apr 15, 2019
  7. blackiyto

    blackiyto
    Expand Collapse
    New Member

    Joined:
    Sep 21, 2019
    Messages:
    3
    Likes Received:
    0
    I'm not sure of the etiquette here regarding old threads founds in search versus starting something new.y


    _________________________________________________
    Dafont Showbox Adam4adam
     
    #7 blackiyto, Sep 21, 2019
    Last edited: Oct 12, 2019

Share This Page

Loading...