Hera 18.04 - Nvidia driver is not working. Nouveau turned off, X server empty

Discussion in 'Hardware Support' started by BedSon, May 15, 2021.

  1. BedSon

    BedSon Thread Starter
    Expand Collapse
    New Member

    Joined:
    May 15, 2021
    Messages:
    1
    Likes Received:
    0
    Hello all,

    I am struggling to install a Nvidia driver for almost two weeks and slowly giving up. I reinstalled the newly Elementary OS probably 5 times already and still cannot find a way how to install the driver.

    I went through many guides on the forum and internet but none of them worked. Now I stuck on the low resolution 640x480 and any driver I installed not working. I have Nvidia GTX 980 graphic card, and last few days tried to install driver 465, 460, 450, 390. Result was: even the "nvidia-smi" showing that driver is installed, the X server is empty and low resolution is still cutting my eyes.

    The secure boot in IOS is turned off, nouveau workaround applied in the config file.

    These are added in: /etc/modprobe.d/blacklist.conf (according: https://newbedev.com/how-to-disable-nouveau-kernel-driver)

    blacklist nouveau
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off

    I tried also these links: none of them worked though :(. Nvidia drivers reset after update and now monitor is "unknown" and stuck in 640x480 Nvidia driver problems on 18.04

    https://github.com/lutris/docs/blob/master/InstallingDrivers.md Completely removing old Nvidia drivers https://forums.linuxmint.com/viewto...sid=47bef6e9d81174f29e405858bcc98d28&start=20 https://forums.linuxmint.com/viewtopic.php?p=1895521#p1895521 Unable to get nvidia running on ubuntu 18.04.2 https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux

    Is there normal way to install a current nvidia driver ? or am I forced to use a nouveau or old 390 version ? (I had old one running when I installed it manually few days ago, but I realized when kernel update will come I had to re-intall it again, so tried to work again on auto updating driver, via additional driver center).

    I will be really grateful if anyone can shade a light and help me. The OS reinstall is not a problem at this time, so I am willing to try any guide, just to have a latest driver working, even after reboot. With proper resolution of course.

    Many thanks.

    (if any output needed please tell me, I will provide it)

    output from nvidia-smi:

    $ nvidia-smi
    Sat May 15 10:04:13 2021
    +-----------------------------------------------------------------------------+
    | NVIDIA-SMI 460.73.01 Driver Version: 460.73.01 CUDA Version: 11.2 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    | | | MIG M. |
    |===============================+======================+======================|
    | 0 GeForce GTX 980 Off | 00000000:01:00.0 Off | N/A |
    | 36% 34C P0 49W / 300W | 0MiB / 4040MiB | 2% Default |
    | | | N/A |
    +-------------------------------+----------------------+----------------------+

    +-----------------------------------------------------------------------------+
    | Processes: |
    | GPU GI CI PID Type Process name GPU Memory |
    | ID ID Usage |
    |=============================================================================|
    | No running processes found |
    +----------------------------------------------------
     
  2. paradise

    paradise
    Expand Collapse
    Elementary Supporter

    Joined:
    Dec 3, 2014
    Messages:
    127
    Likes Received:
    34
    Oh men, you've really tried a lot (and good things).

    Does the nvidia driver work with other distros on your device?

    If not tried yet, I would try it with latest Linux Mint (Cinnamon) stable in your case.
     

Share This Page

Loading...