WLAN Qualcomm Atheros QCA6174 802.11ac

Discussion in 'Hardware Support' started by webcam, Mar 4, 2016.

  1. webcam

    webcam Thread Starter
    Expand Collapse
    Member

    Joined:
    Mar 4, 2016
    Messages:
    5
    Likes Received:
    0
    Hello,
    I have the Win10 said adieu.
    Have installed me Elementary.
    Unfortunately, I do not know how I have to install the WLAN driver.
    Qualcomm Atheros QCA6174 802.11ac
    Can anybody help me further?
    Merci.
     
  2. paradise

    paradise
    Expand Collapse
    Elementary Supporter

    Joined:
    Dec 3, 2014
    Messages:
    124
    Likes Received:
    33
    Hi webcam,

    you need atk10 firmeware. Your Chips Firmeware QCA6174 is available in Kernel 3.20+ (changelog), but elementary runs on 3.13 currently.

    Please try the backport solution from here, you will download the addon-sourcecode for this athk10 module, compile and install it. this way you don't need a kernel 3.20+

    copy-paste line-by-line

    Code (Text):

    sudo apt-get install build-essential linux-headers-generic
    wget https://www.kernel.org/pub/linux/kernel/projects/backports/2015/03/13/backports-20150313.tar.xz
    tar xvfJ backports-20150313.tar.xz
    cd backports-20150313
    make defconfig-ath10k
    make
    sudo make install
     
    And reboot. Let us know if this did resolve the issue :)?
     
  3. webcam

    webcam Thread Starter
    Expand Collapse
    Member

    Joined:
    Mar 4, 2016
    Messages:
    5
    Likes Received:
    0
    Hello,
    have all made such as you wrote above.
    With no command was an error.
    Unfortunately my wireless still does not work.
    Maybe my laptop is too new for Elementary OS.
    I have an ACER Aspire VN7-792G.
    Greeting
    Daniel
     
  4. paradise

    paradise
    Expand Collapse
    Elementary Supporter

    Joined:
    Dec 3, 2014
    Messages:
    124
    Likes Received:
    33
    Hello Daniel,

    my other idea is to install a new kernel. This installation is really simple and i didn't know from any situation where it breaks up something on the notebook. Just copy again, line-by-line in your Terminal, this will download and install kernel 4.4.4 stable (latest).

    If you have 64 Bit Linux installed (amd64)

    Code (Text):
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.4-wily/linux-headers-4.4.4-040404-generic_4.4.4-040404.201603031931_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.4-wily/linux-image-4.4.4-040404-generic_4.4.4-040404.201603031931_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.4-wily/linux-headers-4.4.4-040404_4.4.4-040404.201603031931_all.deb
    sudo dpkg -i linux-headers-4.4.4*all.deb linux-headers-4.4.4*amd64.deb linux-image-4.4.4*amd64.deb
    sudo reboot
     
    If you have 32 Bit Linux installed (i386):
    Code (Text):
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.4-wily/linux-headers-4.4.4-040404-generic_4.4.4-040404.201603031931_i386.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.4-wily/linux-image-4.4.4-040404-generic_4.4.4-040404.201603031931_i386.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.4-wily/linux-headers-4.4.4-040404_4.4.4-040404.201603031931_all.deb
    sudo dpkg -i linux-headers-4.4.4*all.deb linux-headers-4.4.4*i386.deb linux-image-4.4.4*i386.deb
    sudo reboot
     
    GRUB is re-configuring itself automatically, the command sudo update-grub is already done (loading new kernel at boot).

    After reboot, you can type uname -r in your terminal, the answer should be kernel 4.4.4 instead of kernel 3.13

    Does the WLAN work now?
     
  5. webcam

    webcam Thread Starter
    Expand Collapse
    Member

    Joined:
    Mar 4, 2016
    Messages:
    5
    Likes Received:
    0
    Lief again through without an error message.
    Unfortunately still no Wi-Fi.
    But now my flickering screen.
    I install Elementary again new.
    Greeting
    Daniel
     
  6. webcam

    webcam Thread Starter
    Expand Collapse
    Member

    Joined:
    Mar 4, 2016
    Messages:
    5
    Likes Received:
    0
    Hello,
    have now bought a USB WLAN Stick and did everything again reinstalled.
    Detects is the stick, but I believe he will not be activated.

    Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
     
  7. Schorny

    Schorny
    Expand Collapse
    Active Member

    Joined:
    May 27, 2015
    Messages:
    29
    Likes Received:
    7
    hey webcam, i've found a tutorial for your wifi stick. It's german, but just copy-paste the terminal commands from here: https://forum.ubuntuusers.de/topic/wlan-stick-524440/3/#post-5638107

    You can type "uname -a" into your Terminal first to check what kernel you are running on. I guess it is 3.13.80, so the following would be for you:

    Code (Text):

    sudo apt-get install --reinstall linux-headers-$(uname -r) linux-headers-generic build-essential dkms git
    git clone https://github.com/pvaret/rtl8192cu-fixes.git
    sudo dkms add ./rtl8192cu-fixes
    sudo dkms install 8192cu/1.10
    echo "blacklist rtl8192cu" | sudo tee -a /etc/modprobe.d/blacklist.conf
     
    Reboot is now required.

    Let me know if this driver runs :)?
     
  8. webcam

    webcam Thread Starter
    Expand Collapse
    Member

    Joined:
    Mar 4, 2016
    Messages:
    5
    Likes Received:
    0
    Hello,
    GREAT !!
    Works beautifully.
    Thanks for the help here.
    Greeting
    Daniel
     
  9. Schorny

    Schorny
    Expand Collapse
    Active Member

    Joined:
    May 27, 2015
    Messages:
    29
    Likes Received:
    7
    Jeah, nice :)
     
  10. Eric Park

    Eric Park
    Expand Collapse
    New Member

    Joined:
    Aug 3, 2016
    Messages:
    1
    Likes Received:
    0
    Hello @paradise! I did your solution above installing a new kernel and it's working! I have a Samsung ATIV Book 5 with QCA6174 802.11ac and the card is functional now. For some strange reason it won't find my 5GHz networks but as long as Wi-Fi works.

    One problem though. When I booted, it took a bit more than usual and I had a bug report waiting for me when I got to my desktop.

    Problem installing bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.2


    One thing I noticed was that the UnreportableReason said it wasn't an official elementary package. How can I fix this error? Thanks.
     

Share This Page

Loading...