No working Windows 10 entry in Grub after installing Elementary OS

Discussion in 'Installation' started by Scyth, May 18, 2020.

  1. Scyth

    Scyth Thread Starter
    Expand Collapse
    New Member

    Joined:
    Apr 30, 2020
    Messages:
    2
    Likes Received:
    0
    Hi!

    As the title says I installed most recent elementary os on my pc. Unfortunately it was very complicated.

    The setup before installation: Windows 10 was running on sda1, on sdb2 I have a 3tb disk to store files and work. sdc was also there but rarely used. Therefor I planned to install elementary on sdc3.
    During installation I realized Windows had some partition on sdc3 (about 500MB) but also, same size, on sda2 (with sda1 beeing the partition where the data is stored on). I tried installing elementary on sdc with an efi partition... but as expected no luck.

    What I did to get a working elementary / Situation now: I really wanted to get elementary on sdc and tidy up that messy installation. Therefore I deleted the windows partition on sdc, hoping I can reference from grub to sda1.
    First issue was: Grub was giving me no menu. So I edited /etc/default/grub. It looks like this now:


    Now I have added an entry in grub. 40_custom_proxy:


    This uuid leads to sda2 (that one with about 500mb). Grub tells me upon choosing it that I have no such directory (also tried it with sda1 but this one didn't work either).

    As you might see I am not too expierienced with grub but I looked some things and I guess those solutions should work, right? That also means the partition on sdc was the windows bootloader... right?

    How should I procees from here on out? Make a Windows USB start disk? Repair the Windows bootloader? Will that kill grub so I need to reinstall it with a live-usb?

    Thanks for any hints!
     

Share This Page

Loading...