HDMI connected display doesn't work as expected

Discussion in 'Hardware Support' started by williepabon, Dec 4, 2015.

Tags:
  1. williepabon

    williepabon Thread Starter
    Expand Collapse
    Member

    Joined:
    Nov 30, 2015
    Messages:
    18
    Likes Received:
    0
    Hi!
    I have a laptop (HP Pavilion dm4) with Win7 and Elementary Freya (64bit). In Win7 mode I can connect an external display (a TV set) using the hdmi port. It is automatically detected by the OS and I can configure it to either mirror displays (both the laptop screen and the TV screen show the same thing) or external display only (laptop screen is turned off and the external display shows the full content). No problem. I was expecting the same behavior when login in to Freya, but it didn't happen. When setting for mirror displays the system reverts to VGA (640x480) on both the laptop and the external (TV) display, which is useless. And it can't be changed. Setting to external display only does not turn off the laptop screen and I get some strange (weird) behavior. To mention a few: (1) Not all applications open on the external display. Firefox browser opens on the external display but Chrome doesn't. It opens on the laptop. LibreOffice also opens on the laptop screen even though it is activated from the external display. (2) If I open a video(with audio) on Firefox, the video shows on the external display(the TV set) but the audio is heard only through the laptop speakers. Well, this is to give you an idea of the strange behavior.

    Is there a solution for this? Elementary is my main OS and it is annoying to switch to Win7 whenever I want to see content from my laptop on the TV screen. Thanks for any help on this.
     

Share This Page

Loading...