Hera Elementary not booting (goes back to BIOS)

Discussion in 'Installation' started by nox, Jan 24, 2020.

  1. nox

    nox Thread Starter
    Expand Collapse
    New Member

    Jan 24, 2020
    Likes Received:
    Just had my windows 10 pro hard drive die on me and thought it's a good time to switch to a better OS. I'm pretty new to Linux so I did some quick research and found 3 participants to install! Manjaro, Elementary and Fedora. I tried installing manjaro and fedora and got hit with Segmentation fault which I couldn't fix and ended up resulting to elementary.

    **If you want to skip my intro I guess..
    Elementary worked all the way until I got to the end of the installation (i'm guessing...) where my screen went black and pc continued to idle, left it for 15 mins and rebooted. Saw 3 options; *elementary, advanced and system setup. Pressing elementary makes the screen go black and sends me straight to the bios. I am very new to Linux and have no idea how to fix this.. Any ideas?

    Here are my specs, if they can help;
    • CPU: AMD R7 2700
    • GPU: GTX 1050
    • RAM: Team Elite 3000Mhz x2 8GB
    • MB: Asus Prime b450-a

Share This Page